Note

The documentation you're currently reading is for version 2.4.1. Click here to view documentation for the latest stable version.

Installation

Warning

If you had previously installed DC Fabric Automation Suite TP release, please do not install this pack, wait for the new release of DC Fabric Automation Suite. When you install DC Fabric Automation Suite, it installs the compatible version of Network Essentials pack automatically.

Installing Pre-requisites

Network Essentials pack requires gcc plus the libxml2-dev and libxslt1-dev libraries. Before installing Network Essentials pack, please run these commands:

On Ubuntu:

sudo apt-get install build-essential libxml2-dev libxslt1-dev

On Redhat/CentOS:

sudo yum install libxml2-dev libxslt1-dev
sudo yum install gcc

Installing Network Essentials

After installing the above pre-requisites, install Network Essentials pack using:

st2 pack install network_essentials

To install DC Fabric Suite, follow the installation instructions for the DC Fabric Automation Suite